Project

General

Profile

Bugless #60

customs: laserproxy does not come up on startup

Added by q3k about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
hscloud

Description

After a customs power cycle:

░░ The job identifier is 123.
Jun 10 18:06:00 customs laserproxy[575]: E0610 18:06:00.739117     575 kubernetes.go:41] Kubernetes InClusterConfig: unable to load in-cluster configuration, KUBERNETES_SERVICE_HOST and KUBERNETES_SERVICE_PORT must be defined
Jun 10 18:06:00 customs laserproxy[575]: I0610 18:06:00.739569     575 kubernetes.go:42] Mirko: no kubernetes config available...
Jun 10 18:06:00 customs laserproxy[575]: F0610 18:06:00.739885     575 main.go:49] could not listen on laser network: listen udp 10.11.0.1:40200: bind: cannot assign requested address
Jun 10 18:06:00 customs systemd[1]: laserproxy.service: Main process exited, code=exited, status=255/EXCEPTION
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░ 
░░ An ExecStart= process belonging to unit laserproxy.service has exited.
░░ 
░░ The process' exit code is 'exited' and its exit status is 255.
Jun 10 18:06:00 customs systemd[1]: laserproxy.service: Failed with result 'exit-code'.

Doing a `systemctl restart laserproxy` fixes things, but this shouldn't be necessary. Either the laserproxy unit should sequence itself after the network is up, or at least attempt to restart on failure.

Also available in: Atom PDF